It is currently Fri Oct 20, 2017 11:52 pm

All times are UTC - 5 hours




 Page 1 of 1 [ 7 posts ] 
Author Message
 Post subject: Atari 400 wont read 1Mb flashcarts
PostPosted: Sun Jun 20, 2010 5:43 pm 

Joined: Sat Jan 17, 2009 11:41 am
Posts: 4
Location: Chicago, IL
I have a 400. It reads the 8Mb cart just fine and shows the menu.

With a 1Mb cart the menu never displays. I have tested several 1Mb carts with the same result.

The 400 reads other carts just fine. The 1Mb carts work on a 1200XL.

This 400 has a 48K mod installed.

Any suggestions?


Offline
 Profile  
 
 Post subject: Re: Atari 400 wont read 1Mb flashcarts
PostPosted: Wed Jun 23, 2010 2:08 pm 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1035
Location: Cleveland, Ohio
If you power cycle the machine slowly over and over with the cart inserted, does the menu ever come up, or do you consistently get nothing every time?

Steve


Offline
 Profile  
 
 Post subject: Re: Atari 400 wont read 1Mb flashcarts
PostPosted: Fri Jun 25, 2010 9:09 am 

Joined: Sat Jan 17, 2009 11:41 am
Posts: 4
Location: Chicago, IL
A series of power cycles yields corrupted display, or a blank screen or all three 1Mb carts I am testing.

All three 1Mb carts work fine on the 1200. The 8Mb cart and all 48K or less commercial carts work fine on the 400.

Thanks


Offline
 Profile  
 
 Post subject: Re: Atari 400 wont read 1Mb flashcarts
PostPosted: Fri Jun 25, 2010 2:37 pm 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1035
Location: Cleveland, Ohio
Are the 1mbit cartridges progammed with menus created with the Maxflash Studio software?

Can you post or e-mail me one of the workbooks you are using. classics@atarimax.com

Thanks

Steve


Offline
 Profile  
 
 Post subject: Re: Atari 400 wont read 1Mb flashcarts
PostPosted: Sun Jun 27, 2010 2:30 pm 

Joined: Sat Jan 17, 2009 11:41 am
Posts: 4
Location: Chicago, IL
The carts were erased using the Maxflash USB Cartridge. They were then programmed on the 1200 using disk images downloaded from the 1Mb forum.

Attached are the three cartridge images I used to program the 1Mb carts.

Thanks


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Offline
 Profile  
 
 Post subject: Re: Atari 400 wont read 1Mb flashcarts
PostPosted: Sun Jun 27, 2010 11:34 pm 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1035
Location: Cleveland, Ohio
These images were compiled with a old version of the command line maxflash kit. They were made using the -diskpacker option which replaces the OS disk read routines with cartridge read routines.

Any image created with the -diskpacker option will require 64k, since it needs the ram under the OS to replace the OS. At some point I added a on-screen message for carts that require 64k, but these images don't have it.

All the games in these images should be available as XEX files, so you can compile a new cartridge by just going to file->new and then adding the xex images. You should be able to get most of these titles here:

http://ape.dyndns.org:8084/

Steve


Offline
 Profile  
 
 Post subject: Re: Atari 400 wont read 1Mb flashcarts
PostPosted: Fri May 30, 2014 5:43 pm 

Joined: Thu Feb 05, 2004 10:34 am
Posts: 259
Location: NL
I wrote this also in another thread, but another reason why there are issues, is that the 400 (and 800) do have RAS signal on pin S in the cart port in stead of Ph2.

That is easy to fix (will write a howto soon). I had also issues with some games, and with this fix, it is perfect.

Still need to find a fix for the 8Mbit carts though.


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 7 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron