Atarimax Product Discussion Forums
https://atarimax.com/flashcart/forum/

SpartaDos X Problems!
https://atarimax.com/flashcart/forum/viewtopic.php?f=17&t=1336
Page 1 of 1

Author:  Deanp [ Sat Jan 12, 2013 10:04 am ]
Post subject:  SpartaDos X Problems!

Hi,

Just go my MyIDE II cart a few days ago and have been trying to get SpartaDos X to work properly. I have copied the .ROM file onto the FAT32 partition on my CF card and loaded it using the FAT32 Loader. SpartaDos x then seems to load OK. However, when I type DIR at the D1: prompt, I get a '138 Device does not respond' - also when I try to save a modified CAR:CONFIG.SYS file using ED, I get a 'Fail 135' error?

Any ideas what is wrong please? Probably just a newbie error?

Many thanks!

Author:  mr-atari [ Sat Jan 12, 2013 1:21 pm ]
Post subject:  Re: SpartaDos X Problems!

That depends what you want to do with SDX.

If you want MyBIOS access, you need to load F2 first.
And modify the config.sys to read DEVICE SIO /A
Also remove OSRAM after SPARTA.

If you want APT access, you need to init a card (manual) and select APT.
Use the APT utility-disk to setup drives.
Add DEVICE MYIDE.SYS to CONFIG.SYS
and MYIDE.SYS-file to the SDX

See the SDX-package for some help on the 4.8.06 thread.
viewtopic.php?p=6958#p6958
Refer to the SDX-homepage for manual and the SDXimagemanager.
http://sdx.atari8.info/index.php

Success,
Sijmen

Author:  Deanp [ Sat Jan 12, 2013 2:43 pm ]
Post subject:  Re: SpartaDos X Problems!

Thanks for the quick reply. I have now updated the config.sys file and added MYIDE.SYS driver, which now loads when SpartaDos boots and says CF CARD 4GB - so it's now seeing my CF card. Next problem, after this it says Invalid partition table and I still get 138 Device does not respond from a DIR.

Do I need to run FDISK to create a partition? If so, where can I find this file to add to the SDX image as I can't find it anywhere in Google?

Best regards,

Dean

Author:  mr-atari [ Sun Jan 13, 2013 4:02 am ]
Post subject:  Re: SpartaDos X Problems!

Hi Dean,

Use the link to the topic in my first reply.
Run FDISK from the APT toolkit and create partitions.
Assign drive-letters to them and you are ready to go.

Later!
Sijmen.

Author:  Deanp [ Sun Jan 13, 2013 5:26 am ]
Post subject:  Re: SpartaDos X Problems!

Sijmen,

Thank you. Final newbie questions then - can you please tell me how I can access the files within the APT toolkit? How do I load the .ATR file? I have tried loading it from the FAT32 loader, but I get an error message 'error loading OS-B Image' - do I also need to copy an OS-B Rom onto the FAT32 partition on my CF card? Is there any help / basic instructions you can point me at (I can't find specific help on this in the forum)

Many thanks and regards,

Dean

Author:  mr-atari [ Sun Jan 13, 2013 10:35 am ]
Post subject:  Re: SpartaDos X Problems!

Hi Dean,

:?
Question still remains, why you want SDX as newbie?

Yeah, good question. For me easy to follow.....
Normally ATR must be mounted using a SIO.
If you have no SIO-PC link, you need to use your MyIDE-II with MyBIOS for ATR-access.

OK.
Add this in your CONFIG.SYS
USE BANKED
DEVICE SPARTA
DEVICE SIO /A
.....
Create a partition D1: 2000 sectors DD. (load MyBIOS-F2, hold START+SELECT+OPTION, Make.....)
PC: With the DriveManager LBA2 copy the toolkit to partition D1.
Back to the ATARI:
Load MyBIOS-F2, press SHIFT, select fat32-loader, load SDX.
Now you have loaded SDX with MyBIOS-F2 as alternative OS for MyIDE-access.
D1: should now be the toolkit.
run FDISK
Create partitions.
Copy D1 (MyBIOS) to a APT-partition.
Now you have the toolkit in APT and you can omit loading MyBIOS-F2 the next time.
That is if you want to use SDX only.

Not easy, but SDX is for heavy users :)

FAT32-loader:
all you need is on this link:
viewtopic.php?f=17&t=1330

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/