Atarimax Product Discussion Forums

Castle Wolfenstein - Image Loader
Page 1 of 1

Author:  Atari Guy [ Sun Apr 02, 2017 3:12 pm ]
Post subject:  Castle Wolfenstein - Image Loader

I am trying to run Castle Wolfenstein from the image loader. I select ctrl-n for a new game and press Option to reset rank. The game loads but then says "Please remove write protect from this disk. Re-insert disk and press Start".

How do I do this? I tried to setup the card again like it was new. It is an 8GB SD card in a CF Adapter. I did this...

- Select the MyBIOS-F2 from the menu.
- Press SHIFT to return to the cartridge menu.
- Load “Atarimax MyDOS 4.53 Rescue Loader”
- Press HELP 2 times.
- Press T (iniT) then A (auto) and wait. (I don't know what the correct CHS values should be)
- Press K (maKe), 1 (Drive #), 720 <enter> (Sectors #), S (density). Name: BOOT <enter>.
- Press K (maKe), 2 (Drive #), 65535 (Sectors #), D (Density). Name: MYDOS <enter>.
- Press ESC (exit), then Y (save), then ESC again.

- Configure D2: as high capacity. Press O 2 N Y Y 65535 <enter>.
- Configure D8: (sramdisk). Press O 8 N Y Y 3062 <enter>.
- Disable verify for faster write. Press V, then N.
- Initialize D1:
- Initialize D2:
- Initialize D8:
- Write DOS to D1:
- Make sure partition A was not protected...HELP, HELP, W, A, ESC, N, ESC

Everything seemed to work correctly but the strange thing is...all these steps did not clear the SD. My images were still there! Also, I got the same write-protect error with Castle Wolfenstein. Why didn't the drive get wiped out? How do I get past the write-protect error?


Author:  mr-atari [ Mon Apr 03, 2017 2:43 am ]
Post subject:  Re: Castle Wolfenstein - Image Loader

Hi, I assume 4.9.B16 ?

SHIFT+CONTROL+P <beep> toggles RW-access.
That is all.
Images are always Read-only on boot-up.
Because original disks are protected.....

Re-doing MyIDE-setup only overwrites the partition-sector, not your data.
To wipe data, you must select ERASE-ALL, confirm with yes.
Or do a MANUAL init, not AUTO.
But I suggest NOT to do this.

Author:  Atari Guy [ Mon Apr 03, 2017 6:59 am ]
Post subject:  Re: Castle Wolfenstein - Image Loader

Shift-Control-P worked. Thanks.

Do you know how to use MyIDE-II emulation in Altirra? Someone is trying to get some .atrs to work with it. He's able to attach the MyIDE-II device and load the bios. It boots to the menu and he selects #2 - Fat32 Launcher but then it asks to insert a FAT32 formatted CF card. Do you know how to create and attach the CF card in Altirra?

Author:  mr-atari [ Tue Apr 04, 2017 2:53 am ]
Post subject:  Re: Castle Wolfenstein - Image Loader

I use a sector-editor to dump my CF-card to the PC as a file.
(and visa versa) ;-)

In altirra, you have to add this file to your myide-][ device as hardddisk.
Use the CHS settings you get from the Atari, not use the preset values.
Use a filename that includes the CHS values, easy to remember

See picture.

Do not forget to add the 512k myide-][.bin file as rom content for your myide-][ device...

Optionally, you can add the internal MyIDE-][ OS as BIOS, so you do not need to load the F2.
Compatibility-wise this is a great enhancement.
Oh, in altirra, best is to disable all patched then, MyBIOS does not like patched OS-emulation.

Author:  Atari Guy [ Tue Apr 04, 2017 7:09 pm ]
Post subject:  Re: Castle Wolfenstein - Image Loader

Great. Thanks Sijmen!

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group