It is currently Fri Jan 27, 2023 9:00 am




 Page 1 of 1 [ 11 posts ] 
Author Message
 Post subject: FAT32 Error: File Not Found
PostPosted: Wed Aug 24, 2022 6:49 pm 

Joined: Sat Aug 20, 2022 7:26 am
Posts: 8
Is this just a case of a game xex not working in the FAT32 loader portion of the MyIDE-II?

After seeing the error I thought maybe I just had a bad dump, so I got the attached file from Homesoft, with the same results. Then I tried Fandal, again with the same results.

I'm assuming this just means the game won't work (or needs something done to the header or something).

If it's the latter I wouldn't mind knowing what can be done, as if it's easy enough I'd take the time to do it myself. If it's the former I'll just accept it and move on :)


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Offline
 Profile  
 
 Post subject: Re: FAT32 Error: File Not Found
PostPosted: Thu Aug 25, 2022 2:28 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1512
Location: netherlands
I downloaded your file, put it on a CF-card (FAT).
Started my Atari, 800XL-pal, MyIDE-2, loaded the file with atarimax fat32 loader and.....


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Offline
 Profile  
 
 Post subject: Re: FAT32 Error: File Not Found
PostPosted: Thu Aug 25, 2022 10:37 am 

Joined: Sat Aug 20, 2022 7:26 am
Posts: 8
Well that's not the reply I was hoping for. Could there be something wrong with my cart?

I have tried it on an NTSC 800XL and an NTSC 130XE. I have tried it by launching MyBIOS first and then launching the Fat32 loader, and just launching the Fat32 loader itself. The error I see is below.

After both attempts on my 800XL I was able to launch Alley Cat right after without issue.

Note also I am able to load Alpha Shield using SIO2PC on the 800XL (using the MIRROR functionality of APE to allow me to load xex's directly)

Thoughts?


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Offline
 Profile  
 
 Post subject: Re: FAT32 Error: File Not Found
PostPosted: Thu Aug 25, 2022 6:19 pm 

Joined: Sat Aug 20, 2022 7:26 am
Posts: 8
FYI I updated my cart with "MyIDE-ONLY #7" and still get the same message when I try to launch Alpha Shield.

Having said that I *do* like your image so I'm definitely keeping it :)


Offline
 Profile  
 
 Post subject: Re: FAT32 Error: File Not Found
PostPosted: Fri Aug 26, 2022 1:51 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1512
Location: netherlands
Thanks for the feedback, #7 is my best (probably last) update.
I am getting to old for coding....

I do think there is something wrong with either your cartridge or CF-card.
What size / brand are you using?

Grtz,
Sijmen.


Offline
 Profile  
 
 Post subject: Re: FAT32 Error: File Not Found
PostPosted: Fri Aug 26, 2022 6:19 am 

Joined: Sat Aug 20, 2022 7:26 am
Posts: 8
One is never too old for coding IMO, but then again I'm "only" 51 :)

The CF card is an STEC 1GB one. I got it with the MyIDE-II.

I have a SanDisk 256MB I'm going to try instead as I think you're right, it's worth looking in to whether or not the CF card is the problem. I also have a Verbatim 4GB CF card here, but I had thought to return it to Amazon after seeing that the 1GB looked like plenty of space. If the 256MB one works but doesn't seem like it's big enough I'll crack it open and keep it.


Offline
 Profile  
 
 Post subject: Re: FAT32 Error: File Not Found
PostPosted: Fri Aug 26, 2022 7:37 am 

Joined: Sat Aug 20, 2022 7:26 am
Posts: 8
And now I'm having problems with the CF cards I think. Maybe it is the cart.

I popped in the CF 356 after formatting it to FAT32. Ran MyBIOS, Initialized it, Made the image, set it to Disk 1 (all from the Bootstrapping instructional YouTube video).

When I go to pop the card back into my PC it says it's not formatted. I know I've done this before and it worked, so I go back to the 1GB cart and do the same, which also results in the same bad image. So now I'm wondering if my flash of #7 messed it up.

I've got to get to work though so I'll mess with this later. If you can let me know that the Verbatim card will be okay I'll crack that. I think the 256MB one is kinda slow anyway TBH.


Offline
 Profile  
 
 Post subject: Re: FAT32 Error: File Not Found
PostPosted: Fri Aug 26, 2022 10:53 am 

Joined: Sat Aug 20, 2022 7:26 am
Posts: 8
OK, I noticed that after I initialize the partition as per the bootstrap video that after existing it went straight to a memo pad instead of showing me the rainbow screen.

I've seen the rainbow screen in the past after this step so I fear I've done something to the cart.

I did end up using the 4GB CF card, just because I figured why not at this point. And yeah, my PC doesn't recognize it after I finish creating that partition, so I can't even load XEX files on to it right now to test to see if it was the card previously or not.

Advice will be appreciated.

I have the SIO2PC USB hardware so I'm able to flash anything I need to onto the MyIDE-II cart. I know it works ok as I have 8Mbit carts here that I've flashed recently with it without error. Note that the first time I tried flashing my own hardware based on the shipping workbook I tried putting games in the base menu, but it didn't work (even though same ROM worked inside FAT32 loader). That time it was H.E.R.O.


Offline
 Profile  
 
 Post subject: Re: FAT32 Error: File Not Found
PostPosted: Sat Aug 27, 2022 12:31 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1512
Location: netherlands
8bit1337 wrote:
And now I'm having problems with the CF cards I think. Maybe it is the cart.

I popped in the CF 356 after formatting it to FAT32. Ran MyBIOS, Initialized it, Made the image, set it to Disk 1 (all from the Bootstrapping instructional YouTube video).

When I go to pop the card back into my PC it says it's not formatted.


That is correct, after using INIT on MyIDE/MyBIOS, you need to (re-)format the FAT32 portion.
Because the MBR is overwritten by a new one, for FAT and MyIDE usage.


Offline
 Profile  
 
 Post subject: Re: FAT32 Error: File Not Found
PostPosted: Sat Aug 27, 2022 12:34 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1512
Location: netherlands
Can you just only format a card on PC with FAT?
Then put some XEX files on them and see if they load.

If you get the file not found error, there is a issue with IO to CF caused by a cartridge problem.

No way you got a bad flash from using #7


Offline
 Profile  
 
 Post subject: Re: FAT32 Error: File Not Found
PostPosted: Sat Aug 27, 2022 8:42 am 

Joined: Sat Aug 20, 2022 7:26 am
Posts: 8
mr-atari wrote:
That is correct, after using INIT on MyIDE/MyBIOS, you need to (re-)format the FAT32 portion.
Because the MBR is overwritten by a new one, for FAT and MyIDE usage.


Thank you. I think my problem was mostly trying to do this in bits instead of just sitting down to tackle the problem. I was just coming back here to say I figured it out on my own but you were bang on - I had to reformat the CF card in Windows after creating the partition through MyBIOS.

Thank you so much for your help! And for #7 :)


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 11 posts ] 


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron