Atarimax Product Discussion Forums
https://atarimax.com/flashcart/forum/

A800Win PLus emulator supporting Flash write
https://atarimax.com/flashcart/forum/viewtopic.php?f=3&t=694
Page 1 of 1

Author:  Wrathchild [ Sun Feb 03, 2008 3:00 pm ]
Post subject:  A800Win PLus emulator supporting Flash write

Hi,

To assist with the development of titles that can write to the Flash memory I'm posting up the (binary) version of the A800Win PLus 4.0 emulator, itself based on the Atari800 kernel 1.3.6. This also has the debugger enabled and supports some additional useful debug commands (e.g. type 'B ?' in the monitor).

It is possible to use the emulator to test the burning of a MaxFlash disk image to a flash-cart ROM image.

Best wishes,
Mark

Author:  goochman [ Mon Feb 04, 2008 10:24 am ]
Post subject: 

Which specific versions of 800win+ - 4.0/4.1/4.2?

Author:  Wrathchild [ Mon Feb 04, 2008 5:42 pm ]
Post subject: 

Hi,

The original sources were taken from here:
http://www.atariarea.krap.pl/PLus/index_us.htm
And I believe this correlates to 4.0 Beta 7

I've seen the thread regarding the 4.1 and 4.2 but I don't have knowledge of the sources for these being made available?
The Atari "Accelerator" - Atari800winPlus
also this thread has a binary:
Atari800WinPlus 4.1 (2.0.2)

Regards,
Mark

Author:  Shannon [ Thu Mar 05, 2009 7:47 am ]
Post subject: 

Thanks for making this available. I tried running a flash image disk against an appropriately sized cart and it seemed to work ok. The date on the file even updated.

But when I subsequently tried to run the cartridge image nothing would happen. Do I need a certain flash cart image for this to work correctly?

Author:  Wrathchild [ Thu Mar 05, 2009 3:26 pm ]
Post subject: 

Hi Shannon,

Hard to say really, can you post the image used (e.g. was it one from this site) and maybe the resulting image too to analyze?

EDIT: possibly you maybe referring to the Ultima 4 thread image? I tried it and found it looked like it had locked up for me however this was caused by having the SIO patch enabled on the emulator. With that disabled the cart boots properly.

Regards,
Mark

Author:  Shannon [ Sat Mar 07, 2009 7:46 am ]
Post subject: 

Wrathchild wrote:
Hi Shannon,

Hard to say really, can you post the image used (e.g. was it one from this site) and maybe the resulting image too to analyze?

EDIT: possibly you maybe referring to the Ultima 4 thread image? I tried it and found it looked like it had locked up for me however this was caused by having the SIO patch enabled on the emulator. With that disabled the cart boots properly.

Regards,
Mark
Thanks. Turning off the SIO patch did the trick!! :D

Author:  Shawn Jefferson [ Tue Mar 10, 2009 2:32 pm ]
Post subject: 

Mark, I am having some trouble using the Ultima III image I created. It appears to flash correctly, but when you Journey Onward, the screen is full of chests instead of the proper map.

On the real hardware this doesn't happen.

I'm attempting to troubleshoot some issues with the image, and was hoping to use the flashcart enabled emulator to do so. The ATR is here on the site in the 8mb section.

Author:  Wrathchild [ Sun Mar 22, 2009 5:02 pm ]
Post subject: 

Hi Shawn,

Finally found some time to have a debug of the A800 app and found that the flash erase routine was not calculating the memory offset correctly.

Attached is the fixed up version which I hope works OK.

Regards,
Mark

Author:  Shawn Jefferson [ Sun Mar 22, 2009 7:22 pm ]
Post subject: 

Seems to work great! I tested it with the Ultima III image I created that works on real hardware and no problems.

Now I can use it to troubleshoot and complete the Ultima II image I am working on.

Thanks Mark!

Author:  kenfused [ Wed Sep 07, 2011 10:33 pm ]
Post subject:  Re: A800Win PLus emulator supporting Flash write

I have been trying to use the patched emulator to test something I have been working on. When I write to D504 within the erase routine I would expect it to clear out (to FF) offsets $8000-$bFFF in the binary file but it seems to be clearing out 4000-7FFF. Any ideas? I have no problems with the writes, they seem to go to the correct place.

Thanks,
ken

Author:  Wrathchild [ Thu Sep 15, 2011 2:38 pm ]
Post subject:  Re: A800Win PLus emulator supporting Flash write

I'm not sure when I can get a chance to look into this as I've not got the original sources and Visual Studio to hand currently, but the code was like this:

int sector;
if (chip->type == Am010) sector = ((chip->ActiveBank&1)<<2) + ((mem>>13)& 3); // 16K
if (chip->type == Am040) sector = ((chip->ActiveBank>>4)& 7); // 64K
AmdChipErase(chip, sector);

Your change in the binary file looks to be $4000 bytes in length and so I assume a 16K bank size within a 1Mb (128KB) cart. So IIRC, the erase is depending upon the address of your write of the value "0x30" (rather than 0x10 for a full erase) at the end of the sequence.

I'd guess the current bank before starting the erase sequence 'mod 2' would be zero and so would target the lower 4 of the 8 erasable banks. The write to $D504 would give (/8192) a value of '6' and masking off the low 2 bits gives '2'. In theory that would give an offset of $8000 which you were expecting? Or did you set the bank beforehand using $d504 and then the 0x30 write went to a different address?

Not sure if that helps?

Mark

Author:  Greenchili [ Mon Aug 22, 2016 7:00 am ]
Post subject:  Re: A800Win PLus emulator supporting Flash write

Is there any source for this build? I'd like to be able to in-corporate the write ability into the atari800xlbox emulator for the xbox. So that some of the flash images that write to a cart (ultima, etc) can be used with it.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/