Atarimax Product Discussion Forums
https://atarimax.com/flashcart/forum/

Loading problem with .XEX files
https://atarimax.com/flashcart/forum/viewtopic.php?f=5&t=1204
Page 1 of 1

Author:  MrBooka [ Sat Feb 11, 2012 2:24 pm ]
Post subject:  Loading problem with .XEX files

Hello everyone,

I was curious if anyone else is experiencing loading problems using APE and the SIO2PC interface. Mine is a USB interface and I am using Windows 7 64-bit. I load the directory in using the PC-Mirror option and boot my Atari 800. The Atari sees the directory and I then use the APE loader to select the .xex file to load. The file appears to load but not boot. The load stops at address 02E0 every time and using two different .xex files. I am using APE v3.0.2 unregistered. Thanks for the help.

R

John

Author:  classics [ Tue Feb 14, 2012 4:40 am ]
Post subject:  Re: Loading problem with .XEX files

Can you post the EXE file (or a link to it) and some information about the Atari you are trying to load it on?

02E0 is the dos RUN vector, so you would normally see this at the end of most EXE files. If that segment is loading OK, control was probably passed normally to the EXE file, but it may not have run due to compatibility problems with the host OS or hardware configuration.

Steve

Author:  MrBooka [ Thu Feb 16, 2012 12:22 am ]
Post subject:  Re: Loading problem with .XEX files

The two .xex files that I tried are included in the attached zip file. I converted the nukewar.xex to a .cas file and was able to load it. The pacman file is a hack. Both files work in Altari800Win Plus. Thanks for the help.

John

Author:  classics [ Sat Feb 18, 2012 4:55 am ]
Post subject:  Re: Loading problem with .XEX files

Nukewar is loading fine, but its a Basic program. Someone tried to pack it in a exe by turning on the XL/XE internal basic after loading and then trying to unpack some memory to make it look like Basic was already running.

So, its loading, but its only going to run on a machine with the exact right version of Atari BASIC installed, and the exact right version of the OS, since it makes non-vector calls directly into both. I have no idea what the correct combination is, but when you find it, it will probably work.

Here is a fixed version of the pac-man executable that should load properly on real hardware.

Steve

Author:  MrBooka [ Sat Feb 18, 2012 3:10 pm ]
Post subject:  Re: Loading problem with .XEX files

Thanks for the help. Works like a champ.

John

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/