Atarimax Product Discussion Forums
https://atarimax.com/flashcart/forum/

Problems with self-created ATR images
https://atarimax.com/flashcart/forum/viewtopic.php?f=5&t=1917
Page 1 of 1

Author:  windracer [ Tue Sep 27, 2016 8:33 pm ]
Post subject:  Problems with self-created ATR images

Just got my SIO2PC USB adapter and have been experimenting with running ATR images from my PC on my trusty old Atari 800XL. Very cool!

I found three old floppy disks (I think the rest are still in my parents' basement somewhere ... will have to try and recover those next time I'm up north) and tried creating ATR images of them.

My image of PaperClip (word processor, original commercial floppy) seems to work just fine. The other two disks are old SpartaDOS-formatted floppies with various utilities on them (BobTerm, DeTerm, Omnicom, etc.). When using these ATR images and issuing commands (like DIR, or trying to run COM files), I get random errors like "Error -- 138" (timeout), "Error -- 139" (NAK), or "Error -- 140" (serial bus error) or sometimes the 800XL just locks until I press BREAK a few times. Re-issuing the command sometimes works. Programs (like BobTerm) may hang while loading, or may load and then hang randomly later.

When running off the physical (original) disks, everything seems to work fine. So I suspect a problem with the ATR images. Could it be due to bad sectors on the original floppies (they are almost 20 years old) or something else? I've tried creating them with ProSystem and the APE/MYCOPIER method and they seem to both exhibit the same problems.

Any ideas/suggestions? Thanks!

Author:  classics [ Fri Sep 30, 2016 5:02 pm ]
Post subject:  Re: Problems with self-created ATR images

Older/original versions of Spartados support "ultraspeed", but cannot actually handle the baud rate used by most speeder programs and new versions of Spartados, it will randomly lose bytes while doing disk i/o.

To use these versions of Spartados you would need to set the "preferred rate" in the USB adapter setup to 0x10, or maybe 0x0A. If I recall correctly anything lower than NTSC 0x08 will cause the older spartados i/o handler to lose track of some bytes.

Steve

Author:  windracer [ Sat Oct 01, 2016 4:15 pm ]
Post subject:  Re: Problems with self-created ATR images

Thanks for the tip! Sure enough, setting the Preferred Rate to 0x0A seems to have resolved all of the issues!

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/