It is currently Thu Dec 03, 2020 2:57 pm

All times are UTC - 5 hours

 Page 1 of 1 [ 2 posts ] 
Author Message
 Post subject: LEDs on device won't light/unable to establish connection
PostPosted: Tue Jan 03, 2006 9:27 pm 

Joined: Tue Jan 03, 2006 9:18 pm
Posts: 1
Hi folks!

I just hooked up my SIO2PC Interface device I ordered from Atarimax (by way of ebay). I have what may seem a very basic question. I've followed the hook-up instructions carefully, but no matter what I do, the LED lights on the device won't light up when I turn on the Atari or at any other time.

I've tried a variety of software, including the APE Trial, and nothing seems able to establish a connection between the PC and the Atari. I even tried using the cable in Prosystem mode, but I couldn't get the PC to see the disk drive. I'm not sure what I'm doing wrong...if anyone has an idea of what I should do to fix this, I'd sure appreciate your assistance.

Thanks very much for your time,

 Post subject:
PostPosted: Tue Jan 03, 2006 10:47 pm 
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1040
Location: Cleveland, Ohio
Have you tested your Atari with a real disk drive so that you know the SIO port works ok?

If you know that the SIO port on your Atari works normally, and the power LED on the interface wont come on when then Atari is turned on, then the interface is damaged or defective.

If thats the case please e-mail me at and I will arrange a free exchange for a new unit.



Display posts from previous:  Sort by  
 Page 1 of 1 [ 2 posts ] 

All times are UTC - 5 hours

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: