It is currently Thu Nov 14, 2019 6:07 am




 Page 2 of 7 [ 96 posts ]  Go to page Previous  1, 2, 3, 4, 5 ... 7  Next
Author Message
 Post subject: Re: My IDE Drive Manager
PostPosted: Mon Apr 04, 2011 2:01 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1376
Location: netherlands
The error message is very short.
I had to hit printscreen a few times to catch it.

The program is extracted in a folder called "atari myide drivemanger" on drive D:


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Offline
 Profile  
 
 Post subject: Re: My IDE Drive Manager
PostPosted: Mon Apr 04, 2011 6:28 am 
User avatar

Joined: Fri Aug 29, 2003 4:37 pm
Posts: 229
Location: Arizona USA
I get a error screen also.
Is this a command line program?

Attachment:
MyIDE Drive Manager failed.png


There are images and/or files attached to this posting. You must be logged-in to view or download this content.



_________________
Roydea6
Offline
 Profile  
 
 Post subject: Re: My IDE Drive Manager
PostPosted: Mon Apr 04, 2011 10:38 am 
User avatar

Joined: Mon Jan 12, 2004 5:01 pm
Posts: 84
Location: Reading UK
Is it feasible that the utility could be used to work against an Altirra generated MyIDE disk image file rather than a physical device?


Offline
 Profile  
 
 Post subject: Re: My IDE Drive Manager
PostPosted: Mon Apr 04, 2011 3:21 pm 

Joined: Wed Mar 04, 2009 7:27 am
Posts: 98
Location: United Kingdom
Is this supposed to work with the LBA version of MyIDETool which Hias wrote for the SDX MyIDE Driver?



_________________
The Last Word, MA65 Assembler, RIF SpartaDOS Utilities, XEDIT
Offline
 Profile  
 
 Post subject: Re: My IDE Drive Manager
PostPosted: Tue Apr 05, 2011 10:06 pm 

Joined: Sat Oct 23, 2010 6:08 pm
Posts: 35
OK, thanks for the screenshots (I've fixed things so the error dialog stays until OK is pressed - I was showing it from a non-UI thread!).

Now I know where it's failing - however I'm really not sure why.

So.. I've added yet more details to the error report, so I can see what's going on (myidetool.exe seems to be emitting something I'm not understanding).

Give it a go one more time, please gents..

Thanks!

..Kieran
PS. I'm not ignoring the other questions. The myidetool.exe in this version is the latest one if that helps.


Offline
 Profile  
 
 Post subject: Re: My IDE Drive Manager
PostPosted: Wed Apr 06, 2011 5:11 am 

Joined: Wed Mar 04, 2009 7:27 am
Posts: 98
Location: United Kingdom
Grunty wrote:
OK, thanks for the screenshots (I've fixed things so the error dialog stays until OK is pressed - I was showing it from a non-UI thread!).
PS. I'm not ignoring the other questions. The myidetool.exe in this version is the latest one if that helps.

I understand - thanks. I just wasn't sure if Hias had yet publicly released the version he wrote for my SDX driver, or at least sent you a copy. I'm gonna have to sit down and give this a go, then I'll be able to formulate my questions more clearly. :)

Urgh... I tried the latest build under Windows 7 and it just crashes on startup. The error message isn't around long enough to read...



_________________
The Last Word, MA65 Assembler, RIF SpartaDOS Utilities, XEDIT
Offline
 Profile  
 
 Post subject: Re: My IDE Drive Manager
PostPosted: Wed Apr 06, 2011 8:42 pm 

Joined: Sat Oct 23, 2010 6:08 pm
Posts: 35
Please grab another copy from the link I posted before.. The 'Pre' subfolder is the one you need.

.. Kieran ( from my phone )


Offline
 Profile  
 
 Post subject: Re: My IDE Drive Manager
PostPosted: Wed Apr 06, 2011 8:44 pm 

Joined: Sat Oct 23, 2010 6:08 pm
Posts: 35
Here's the link again..

http://home.kindredintellect.com/atari/ ... nager/Pre/

.. Kieran


Offline
 Profile  
 
 Post subject: Re: My IDE Drive Manager
PostPosted: Thu Apr 07, 2011 4:52 am 

Joined: Wed Mar 04, 2009 7:27 am
Posts: 98
Location: United Kingdom
That's the one I was using. It craps out on startup saying MyIDETool can't find an appropriately partitioned card. I replaced the supplied version of MyIDETool with the latest version Hias sent me and I still get the same error. Running both as admin doesn't help. This is after I'd already used the same copy of MyIDETool to successfully access the same partitions on the same card via the command line.



_________________
The Last Word, MA65 Assembler, RIF SpartaDOS Utilities, XEDIT
Offline
 Profile  
 
 Post subject: Re: My IDE Drive Manager
PostPosted: Thu Apr 07, 2011 4:06 pm 

Joined: Sat Mar 12, 2011 12:06 pm
Posts: 24
When the "Tools" directory isn't available it crashes on my Windows XP.
When the "Tools" directory IS available, it gives the (brief) error message

Hope it helps


Offline
 Profile  
 
 Post subject: Re: My IDE Drive Manager
PostPosted: Thu Apr 07, 2011 6:09 pm 

Joined: Sat Oct 23, 2010 6:08 pm
Posts: 35
This is quite frustrating.. I can't seem to repro this problem at all!

You will cetaily always need the Tools directory at the same level as the EXE itself.

OK, I think I've finally fixed the vanishing error dialog.. it should stay up and report useful information.

Updated in place:
http://home.kindredintellect.com/atari/MyIDEDriveManager/Pre/

It appears that for some reason myidetool isn't able to get the physical drive information.

Something to try is run: Tools\myidetool.exe --list from an admin command prompt and posting the output here (please try the one from my .zip as well as any others you have lying around :) ). Here's my machine (Win7 x64):

Tools\myidetool.exe --list

MyIDE Tool V0.40
(c) 2006-2010 by Matthias Reichl <hias@horus.com>
\\.\PhysicalDrive0: 60801/255/63 C/H/S, 476937MB
\\.\PhysicalDrive1: 182401/255/63 C/H/S, 1430796MB
\\.\PhysicalDrive2: 182401/255/63 C/H/S, 1430796MB
\\.\PhysicalDrive3: 36483/255/63 C/H/S, 286181MB
\\.\PhysicalDrive4: 45600/255/63 C/H/S, 2861578MB
\\.\PhysicalDrive5: 91201/255/63 C/H/S, 715402MB
\\.\PhysicalDrive6: 121601/255/63 C/H/S, 953867MB
\\.\PhysicalDrive7: 121/255/63 C/H/S, 949MB

Thanks!

..Kieran


Offline
 Profile  
 
 Post subject: Re: My IDE Drive Manager
PostPosted: Thu Apr 07, 2011 7:33 pm 
User avatar

Joined: Fri Aug 29, 2003 4:37 pm
Posts: 229
Location: Arizona USA
still fails to run. I verified that myidetool.exe saw the drive and even backed up the three partition on it.

MyIDE Tool V0.40
(c) 2006-2010 by Matthias Reichl <hias@horus.com>
\\.\PhysicalDrive0: 121601/255/63 C/H/S, 953867MB
\\.\PhysicalDrive1: 77825/255/63 C/H/S, 610477MB
\\.\PhysicalDrive2: reading drive geometry failed
\\.\PhysicalDrive3: 124/255/63 C/H/S, 972MB
\\.\PhysicalDrive4: reading drive geometry failed
\\.\PhysicalDrive5: reading drive geometry failed



_________________
Roydea6
Offline
 Profile  
 
 Post subject: Re: My IDE Drive Manager
PostPosted: Thu Apr 07, 2011 7:53 pm 

Joined: Mon Aug 04, 2008 1:46 pm
Posts: 18
hi Grunty,

We are in the same, the application fails to start....... :( :( :( :( :( There will be some flaw in the packaging of visual studio. net :?:

C:\MyIDEDriveManager\Release\Tools>myidetool --list
MyIDE Tool V0.40
(c) 2006-2010 by Matthias Reichl <hias@horus.com>
\\.\PhysicalDrive0: 60801/255/63 C/H/S, 476937MB
\\.\PhysicalDrive1: reading drive geometry failed
\\.\PhysicalDrive2: 1/255/63 C/H/S, 7MB
\\.\PhysicalDrive3: reading drive geometry failed
\\.\PhysicalDrive4: reading drive geometry failed

C:\MyIDEDriveManager\Release\Tools>

:idea: :idea: :idea: will not be is an application for 64-bit and not 32bit? :idea: :idea: :idea:

regards


Offline
 Profile  
 
 Post subject: Re: My IDE Drive Manager
PostPosted: Thu Apr 07, 2011 8:41 pm 

Joined: Sat Oct 23, 2010 6:08 pm
Posts: 35
The real problem is related to the failure to read the drive geometry.

Both UI and tool are compiled 32bit, so should work on both without issue.

I'll figure out why my code isn't doing the right thing with the tool output.

Different attempt at error reporting (after reading about a bug in WPF message boxes..) updated in place..

http://home.kindredintellect.com/atari/MyIDEDriveManager/Pre/

Also, can you post the output of what you get for myidetool.exe -l on your physical drive.

Here's mine:

Tools\myidetool.exe \\.\PhysicalDrive7 -l

MyIDE Tool V0.40
(c) 2006-2010 by Matthias Reichl <hias@horus.com>
MyIDE 3.x/4.x CHS partition table:
1942 cylinders 16 heads 63 sectors (1008 sectors per cyl)
Image space: first cylinder: 256 cylinders per slot: 2 total slots: 843
partitions: 2 option byte: 00000000 drive bits: 00000011
part active drv start end dns sectors
1 yes D1: 1 67 DD 65535
2 yes D2: 67 133 DD 65535
3 no D0: 0 0 SD 0
4 no D0: 0 0 SD 0
5 no D0: 0 0 SD 0
6 no D0: 0 0 SD 0
7 no D0: 0 0 SD 0
8 no D0: 0 0 SD 0

Thanks!

..Kieran


Offline
 Profile  
 
 Post subject: Re: My IDE Drive Manager
PostPosted: Thu Apr 07, 2011 10:20 pm 

Joined: Mon Aug 04, 2008 1:46 pm
Posts: 18
hi Grunty,

are the same, but this my info :( :( :( :( :( :( :( :(

C:\MyIDEDriveManager\Release\Tools>myidetool \\.\PhysicalDrive2 -l
MyIDE Tool V0.40
(c) 2006-2010 by Matthias Reichl <hias@horus.com>

MyIDE 3.x/4.x CHS partition table:
490 cylinders 2 heads 32 sectors (64 sectors per cyl)
Image space: disabled
partitions: 1 option byte: 00000000 drive bits: 00000001
part active drv start end dns sectors
1 yes D1: 1 13 SD 768
2 no D0: 0 0 SD 0
3 no D0: 0 0 SD 0
4 no D0: 0 0 SD 0
5 no D0: 0 0 SD 0
6 no D0: 0 0 SD 0
7 no D0: 0 0 SD 0
8 no D0: 0 0 SD 0

C:\MyIDEDriveManager\Release\Tools>

regards


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 2 of 7 [ 96 posts ]  Go to page Previous  1, 2, 3, 4, 5 ... 7  Next


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron