Atarimax Product Discussion Forums
https://atarimax.com/flashcart/forum/

How to built in an MyIDE + Flash Cartridge
https://atarimax.com/flashcart/forum/viewtopic.php?f=7&t=1222
Page 1 of 1

Author:  Sysop*Marius [ Sun Mar 25, 2012 2:48 am ]
Post subject:  How to built in an MyIDE + Flash Cartridge

Hi.

The original first release of MyIDE cart only used:

A0, A1, A2
D0..D7
RW
O2
IO (CCTL)
+5v and GND

When I connect all these wires to the internals of the Atari, and a modern MyIDE Flash cartridge it seems not to work.

When I connect all these wires to the original non-flash based, Mr. Atari MyIDE it works fine.

When I look at the modern cart I see almost all cart connections points are used. Does this mean these carts do also use the other Address lines? Also for IDE?

Thanks for any help
M.

Author:  mr-atari [ Mon Mar 26, 2012 3:31 am ]
Post subject:  Re: How to built in an MyIDE + Flash Cartridge

I guess the GAL-logic uses A0-A13 to select D50x window for CCTL access to the IDE-module.

Author:  8-bit [ Tue Mar 27, 2012 9:41 am ]
Post subject:  Re: How to built in an MyIDE + Flash Cartridge

In the cartridge version (home built), part of the wiring instructions say that the trace to pin A should be cut. Would this have anything to do with the problems you are having in that possibly the MyIDE software is getting overwritten?
Mind you, this is just a thought.

Author:  Sysop*Marius [ Tue Mar 27, 2012 2:56 pm ]
Post subject:  Re: How to built in an MyIDE + Flash Cartridge

Hi 8-bit,

Thanks for your reply; no it is probably what Mr. Atari wrote. Pin A = RD4. That has something to do with the Atari 'thinking' there is a cartridge installed, and the reserved/dedicated RAM for cart is preserved/used.

With my wiring the MyIDE was not working at all, so probably I need to use all the Address lines and not only A0..A2

Greetz
M.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/