Atarimax Product Discussion Forums
https://atarimax.com/flashcart/forum/

xegs rom basic
https://atarimax.com/flashcart/forum/viewtopic.php?f=7&t=1242
Page 5 of 5

Author:  mr-atari [ Fri Jun 15, 2012 1:57 am ]
Post subject:  Re: xegs rom basic

Hi,

On MSN you are off-line and I can not send a off-line chat-message.

Listen,
When you get the IDE-MENU, the interface is OK.
The BIOS checks the interface and media.
If OK you get the MENU if BAD you get nothing.

Please put the SD away. CF is fine, 4Gb is fine.

Did you try the manual init?
press SHIFT-I

Author:  pancioalbe [ Fri Jun 15, 2012 7:21 am ]
Post subject:  Re: xegs rom basic

i press shift and i

c: ???? h: ???? s:???

after?

Author:  mr-atari [ Fri Jun 15, 2012 8:00 am ]
Post subject:  Re: xegs rom basic

mr-atari wrote:
Use the CF card.
I know 100% it works.
SD you can do later.

Do manual init.
SHIFT-I
cylinder head sectors

make D1 1040 sectors SD
ESC (Save) Yes
CF in PC, load drivemangerLBA2
Click on partitions
copy MyDOS MD FAT32i.ATR to d1:
CF in ATARI
Boot

Good luck :-)

Author:  pancioalbe [ Fri Jun 15, 2012 5:36 pm ]
Post subject:  Re: xegs rom basic

I have followed guide ,

when you/they must be c, h, s?

I make d1 d2. but when I put cf in void pc and changed



if I don't put cf neïï ciucuito my ide, myide menu appears and I can make etc d1 1040 and to save the job

I have put the led ,

the led is always turned on but light is low and always turned on

:(
pin1 ide gnd i have 3,3 v after reistor

Author:  mr-atari [ Sun Jun 17, 2012 2:39 am ]
Post subject:  Re: xegs rom basic

Sorry, I really do not understand anymore.

I guess the translator english <-> italian is not helping us out.

Do you have a friend who can help you out in English?
Dutch or German is also fine :-)

Author:  pancioalbe [ Sun Jun 17, 2012 11:24 pm ]
Post subject:  Re: xegs rom basic

you excuse me.

I connect adapter cf to atari, with inserted cf, I press shift The I shape as written in the manual, I press esc / Yes.
I put cf in the pc and cf he/she is original.
I connect adapter cf to atari without cf, I press shift The I shape as written in the manual. I press esc / Y.

I think that with or without cf for myide not and different.

I think that 7404 that I have it doesn't do well his/her job

Author:  mr-atari [ Mon Jun 18, 2012 1:56 am ]
Post subject:  Re: xegs rom basic

Without CF the menu does not come.
So if you have a menu and no CF inserted, that is impossible.

The interface you made is bad, please check all wires.

Or buy one from atarimax here:
MyIDE Internal Interface for XEGS Computer
http://www.atarimax.com/myide/documentation/
$65 dollar

Author:  8-bit [ Mon Jun 18, 2012 9:50 am ]
Post subject:  Re: xegs rom basic

I also have a MyIDE external cartridge that I am using with a 512meg Transend CF card.
I can verify that it works with both the original and updated BIOS.
And I have to say that I had tried three times to build an external MyIDE and failed on all builds.
So I am going along with Mr. Atari in saying you can save yourself a lot of headaches by ordering the MyIDE from classics.
Also, make sure you are using the correct software for your device!
If you built the external one use the software for it.
If you built the internal one, use the software for it.
If you boot with your MyIDE and CF card attached and run the FDISK.BAS program, and it gives you a message of NO HARDDRIVES found, you have a wiring problem on your MyIDE interface.

Sorry if I was not supposed to jump in here, but I thought my experience to be relevant.
The last thing I should mention is that I used the autodetect values as my CF card settings.

Author:  pancioalbe [ Mon Jun 18, 2012 10:40 am ]
Post subject:  Re: xegs rom basic

I have built a circuit following the scheme and I have re-checked the connections a lot of times. On Pin 1 of cable ide I find + 3.3 v.
i have found the following chips: 74ls245 , 74ls32 e 7404.
The menu appears if I connect the adaptor, but it appears if I don't connect, also.
I turn on atari in the menu ide choose I on the screen appears the writing wait, but anything changes, also after 15 minutes.
If I choose SHIFT I in the menu , appear the writing C: next H: next S: I enter values that I have found on internet, Then I follow d1 1040 guide, push button ESC and then YES.
I put the cf into the pc and anithing changes. I open the program you suggested but it doesn't find any partitions where MY DOS can be copied.

Author:  8-bit [ Thu Jun 21, 2012 3:23 am ]
Post subject:  Re: xegs rom basic

You format and write MyDos to the partitions from the Atari, not the PC!
And in my case, the Atari created partitions did not show using the disk manager in Windows XP.
If after creation of partitions on the Atari, they do not show when accessing the FDISK program again (without writing on exit), the write to the drive failed.

Author:  mr-atari [ Fri Jun 22, 2012 2:06 am ]
Post subject:  Re: xegs rom basic

pancioalbe:
Try this:

Atari + CF:
Boot into BASIC and peek the IDE-registers.
Post the values here at the forum.
10 FOR I=0 TO 7
20 ? PEEK(53504+I)
30 NEXT I
RUN

Then try and store a value and read the content back.
Use register 53509, just poke a value and peek.
POKE 53509,170
? PEEK(53509)
What do you get?

This register is 8 bit deep, so any value between 0-255 must be stored.

Later,
Sijmen.

Page 5 of 5 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/