Atarimax Product Discussion Forums

MyIDE build it yourself question
Page 1 of 1

Author:  8-bit [ Sat May 19, 2012 1:43 pm ]
Post subject:  MyIDE build it yourself question

I finally finished the card.
First, the good news.
When I pulled it into the cartridge slot with no drives connected to it, the 65XE powered up to the ready prompt.
Then I connected the CF2IDE adapter with a 512meg Transend CF card in the adapter,
The Power light and CF card detected light came on.
But the 65XE was setting at a black screen with no further activity.
So I am now concerned that the wiring on the MyIDE card may be incorrect.
I would not have thought I should see a black screen on power up.
To conserve the 65XE and not hurt it, I now have a choice of trying to retrace my rats nest of point to point wiring or break down and just order the ready made one.
In other words, I should not be powering up to a black screen I think.
Also, so far, the 65XE has survived this.

PS. Is it possible that the CF2IDE adapter is drawing too much power from the Atari that is causing this black screen?
The CF2IDE adapter mfg. is Creative I/O. and none of the specs show power consumption.
Do you think I should try it with an external power source?
I spoke too soon. I rechecked my wiring and now have the 65XE booting to a Ready prompt with the combination connected.
I then booted from the Mast-31A disk and from there switched to the Util31.atr, pressed Select to boot that, and tried to run FDISK.BAS.
Did I have to press RESET somewhere in the process to activate things? It seems I read that the driver was not activated until RESET was pressed on the Atari.
Do I have to load the UNIDRV.OBJ file?
I am at a complete loss here.
The Power LED and the CF detect LED are both lit when I power up the 65XE.
The drive/CF card, is not being recognized at all.

I guess what I really need at this point is step by step instructions as to what atr image to boot in order and any keys that need to be pressed on the Atari.
So close and yet so far away!

Author:  mr-atari [ Sun May 20, 2012 1:39 am ]
Post subject:  Re: MyIDE build it yourself question

Perhaps you mixed up A0-A2 or D0-D7 wires.

In BASIC: poke(53504)-poke(53511)

and post the values here.

Author:  8-bit [ Sun May 20, 2012 2:46 am ]
Post subject:  Re: MyIDE build it yourself question

I booted from the utility disk with the adapter+CF card attached and after basic appeared, tried your instruction.
I assume you meant a peek of those addresses.
If that is the case, I am getting a value of 255 for each of the addresses.
And that is also the value just powering up to basic without any boot of anything.
As I said, I am completely lost at present. I do not know if I have to be loading any drivers for the adapter+CF card to be recognized or which to load.
Without the benefit of a factory MyIDE cartridge that already loads the required drivers, I just do not know what atr,s to boot from in the MyIDE3 collection from the zipped file.

Author:  mr-atari [ Sun May 20, 2012 5:17 am ]
Post subject:  Re: MyIDE build it yourself question

Relax, all is fine.

Yeah, sorry, peek it is :-)

To test the interface itself, you do not need any drivers.
Value 255 = no IDE attached.

1/ the CF is getting no power: check jumpers, check if pin20 is connected to 5 volt.
2/ The adapter is set to slave not master.

Since you DIY, most likely you need to solder 5 volt to pin20 of the IDE-connector.
That is not in my schematics.

Then boot-up again and see if you get any values from the 8 registers.
Please report the values you read in sequence of 53504-53511

After that, you can try the util31 and run FDISK.


Author:  mr-atari [ Sun May 20, 2012 11:10 am ]
Post subject:  Re: MyIDE build it yourself question

If the CF is getting power and you still get 255 on each register,
perhaps you wrongly connected the LS245

Author:  8-bit [ Mon May 21, 2012 3:29 am ]
Post subject:  Re: MyIDE build it yourself question

I triple checked my wiring and it appears to be good.
But since the 74ls245 came from removing from some very old networking equipment, and it got a fair amount of heat in removing it, it may be very possible that that chip and maybe the others did not survive the de-soldering.
So to save your sanity and mine, it looks like I will have to get the money ahead and get a factory MyIDE cartridge from Steve.

Author:  mr-atari [ Mon May 21, 2012 5:27 am ]
Post subject:  Re: MyIDE build it yourself question

Perhaps I'm not awake last time....
Confusing sometimes doing multiple emails at a time....

Did you say internal or external IDE?
port $D1xx or $D5xx

If you made an external one, you need to peek these values instead.


So. Put in the IDE-media and just bootup your atari into basic.
Then peek.


Author:  8-bit [ Mon May 21, 2012 1:52 pm ]
Post subject:  Re: MyIDE build it yourself question

I am sorry to say that even those new memory locations report 255 using peek.
On the first page of Build your own MyIDE, Pin 1 of the IDE connector is shown as being connected to 5volts through a 4.7k resistor.
I connected it to cart port number 13 and I also connected IDE pin 38 through a 4.7k resistor to cart port number 13.
I have as of yet not been able to get the Atari to recognize the existence of the external MyIDE device.
I am now wondering if it is not a matter of data and address lines being wrong, but instead r/w or chip enable being wrong.
I am now at the point as to ignoring the example schematic and just connecting everything as shown in the schematic on page one.
So I guess I will have to get back to you on the results of that.

Author:  mr-atari [ Tue May 22, 2012 12:36 am ]
Post subject:  Re: MyIDE build it yourself question

Hmmm, strange. The example works for many people.
Shown is the component-side.
The schematics should be correct.
Let me know when you are ready for the next tests :-)

pin 13 is indeed Vcc (is also mentioned and connected in the schematic).

You did test the interface with a IDE-media attached?
The interface itself is passive, giving you always 255 when not loaded with a device.
And sure the IDE-media is powered on?

With the atari booted in basic and no drivers needed, you can always read the 8 IDE-registers
at the locationes mentioned earlier. external ($D500) being different from internal ($D100)


Author:  8-bit [ Wed May 23, 2012 7:22 am ]
Post subject:  Re: MyIDE build it yourself question

After spending an all nighter building yet another interface, I am getting random memory values for peek(54528) and the rest of them show as 255.
And when I say random, I do not get the same value on a reboot or for that matter, pressing RESET.
So at this point, even though others may have had no problems, I am going to hang it up so to speak and just order one from Steve.
I am off from here to leave him a PM to that effect.

PS. I did do all my checks with the IDE2CF adapter and a Transend 512meg CF card attached to the interface.
But I have had a strike against me all along in that I have been using chips I unsoldered from old boards. I also had used a perf board and an edge connector from yet another board that I superglued to the perf board.
And I checked all points on that edge connector to make sure no two points were connected.

Anyway, I could say "It has been Fun", but for the time I have invested in the two adapters, it is just not worth trying to troubleshoot them when the fault could be the chips themselves.

Gotta leave Steve that PM and get some sleep!

Author:  Sysop*Marius [ Wed May 23, 2012 3:13 pm ]
Post subject:  Re: MyIDE build it yourself question

Hi there,

I can confirm that the schematic on this page is correct. I have built a few of these, and it works.

But: do not forget to add the LS573 fix to this too. Perhaps Mr. Atari could update his schematic one day with the LS573 fix added.

With that LS573, MyIDE is really amazing.

One more thing: Although in the development-phase Sijmen found out that "F" versions of the logic gates worked better; my experience is that with the LS573 fix added, the "LS" versions of the logic gates do work slightly better.

It's incredible that such a simple design, in combination with the latest MyBIOS ROM, work so fabulous well.

Author:  8-bit [ Mon Jun 04, 2012 2:46 am ]
Post subject:  Re: MyIDE build it yourself question

I have already ordered a MyIDE cartridge from Steve, but just for fun, with the homebuilt attched with the CF2IDE interface, if I run FDISK.BAS, I get no hard drive attached.
If I in direct mode type in "FOR A=54528 to 54535:? PEEK(A):NEXT A" I get
0 2 1 3 0 0 160 80.

I was actually close one other time and had FDISK find a drive, but got a major error of not being able to read from it.
It is one of the things I may still play with, but for now, I will be waiting for the ordered cartridge that is due to be shipped on Monday June 4th.
Thank you for your efforts to help me though.

Author:  mr-atari [ Mon Jun 04, 2012 4:28 am ]
Post subject:  Re: MyIDE build it yourself question

Hmmm that is interesting.
The values are almost ok.
The values after booting into BASIC (do not run any programm) schould be x 1 1 1 0 0 0/160 80/82
x= does not matter
value/value either one of thoose.
The 2 is read from the error register.
2 means track 0 not found, so something is wrong with your CF-card. (jumper set to 5 volt?)
The 80 is read from the status register.
80 means drive is OK to accept commands.

Author:  8-bit [ Mon Jun 04, 2012 4:37 pm ]
Post subject:  Re: MyIDE build it yourself question

I started to think I had a bad CF2IDE adapter. So I hooked it up in a USB hard drive enclosure and found I could read from it, and write to it just fine.
In the process, I also deleted the original partition and made two new fat 16 partitions on the CF card as well as copying some files to the 2nd partition. So that adapter works.
When I cursor up to the command I gave in the previous post though the values from the peeks do not remain consistent.
I went back and checked for cross wiring on the MyIDE adapter and found none. So I do not know what is causing the values to change.
Also, when I boot from a disk image using aspeqt, I see some lines along the line of saying "Command for device 4F ignored while booting.
I do not know what that is supposed to mean and when I try with APE I do not get those messages.
Also, in the wiring instructions I see the line that pin 38 should be connected to 2 with a 4.7k resistor.
There is no such instruction for for pin 1 of the IDE connector although it is shown as connecting to a 5volt source with another 4.7k resistor.
I am assuming that the "2" means the 2 in the schematic and not cartridge edge connector pin 2.
Are both needed?
I currently have both connected to a 4.7k resistor and from there to connection point 2 which is 5 volts.
I do not know specifically what tells FDISK that there is a drive present and that seems to be the message I am consistently getting when I try running FDISK.BAS.
I have tried booting with both the A and B masters and from there to the utility disk and also tried bypassing them and booting directly from the utility disk.
How do they say, "So close and yet so far away."
I suppose I should also mention that I tried with a physical laptop drive connected and still got the same "No harddrives found".

Author:  mr-atari [ Tue Jun 05, 2012 3:57 am ]
Post subject:  Re: MyIDE build it yourself question

No idea at the moment.
Your remarks are all correct, so there is no issue there.
FDISK is a basic program, you can list it.
You can delete the small detection that checks D500 interface, and just program that this interface is found.
I made the program last century, so I have no clue anymore. All my current work is in assembly :)
But I'm sure there are some REM lines in the source.

ah, easy.
change this
150 GOTO 220
This will skipp if it can write to a register.
Hmmmm, can't write?
Perhaps you made an error in the R/W connections?


Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group