Atarimax Product Discussion Forums

Home_built MyIDE external with stock Atari OS chip help
Page 1 of 2

Author:  8-bit [ Mon Jun 25, 2012 2:08 am ]
Post subject:  Home_built MyIDE external with stock Atari OS chip help

I have now built two MyIDE interfaces and have no provision to burn a new MyIDE OS chip for my 65XE.
I want to be able to get step by step instructions for setting it up with either the 3.2 or 4.7F BIOS.
My experience so far is that I attached a 1.5gig Toshiba 2.5 hard drive to the factory MyIDE with Flash cartridge
that I had reflashed the flash with 4.7 BIOS.
It found the drive, and my steps were
(1) init drive.
(2)set up a 720 sector partition and a 65535 partition
(3) formatted and wrote MyDOS to both partitions
(4) tried to use the INSTALL47DE.atr to install the 4.7 BIOS to the drive.
I have no means of making a new OS chip for the 65XE and with 3 different PCs, I would not want to have to buy a burner and burn a
new OS chip for 3 800XLs, a 65xe, a 600XL with 64k memory upgrade, and an 800 with 64k memory upgrade.
(5) With the factory cartridge with flash of 4.7F, the drive booted fine.
(6) With the home-built external, the LOAD47DE failed.
(7) with the INSTALL47DE.atr, the boot took me to memopad (No booted software)
(8) in that mode, I had no access to any 4.7 main menu
(9) But ALT-CTRL-TAB would bring up the one line menu of ESC RESET ......etc.
(10)So how do I get it to boot to the 4.7 main menu?
(11) Or is this an almost compatible drive problem with no work around?
(12) Did I use the right steps in the right order?

Help needed.

PS. I currently have a 512meg CF card with the Atari factory MyIDE w Flash working.
But I want to be able to use the home-built interfaces as well.

Also, the manual states:

Currently removed: The diskette version of the MyBIOS uses sectors 6-70 to store a copy of the MyBIOS for a fast second stage boot after a 3 sector bootdisk.
This is for users that have NO MyBIOS installed, no flashrom to boot the MyBIOS from or just want to try the new BIOS without removing the current version.

So how does one reserve sectors 6-70 for installation of the 4.7 BIOS using INSTALL47DE.ATR?
I did not reserve any space and I think I am getting a crippled in compete install of it.

Author:  mr-atari [ Mon Jun 25, 2012 2:31 am ]
Post subject:  Re: Home_built MyIDE external with stock Atari OS chip help

Since you switched from PM to posting, I reply here.

For instructions, read the manual that comes with the MyBIOS.
This will also the explain the letter combinations behind the version.
Read the 4.7 post itself for the new issues compaired to the older 3.5
Versions below 3.5 are obsolete.

I tested the situation you wrote down.
All works here.
-setup a 2.5" drive with the ATARIMAX with 4.7F
-switch to homebrew interface
(BIOS is loaded from SIO and written to IDE and started): loading MyDOS from the D1:partition from IDE
-boot LOAD47DE
(BIOS is loaded (fast) from IDE and started): loading MyDOS from the D1:partition from IDE

Test the registers in BASIC or run FDISK.BAS, as instructed in my pm.
If you get errors, your interface is bad or drive incompatible.
With incompatible drives, do the 74LS573-modification to buffer the adress-lines A0-A3

Test your 2.5"drive with the ATARIMAX, with LOAD47DE.ATR and hold SHIFT when pressing enter.
If it boots, you see the setup works, thus the problem is in the homebrew

Author:  8-bit [ Mon Jun 25, 2012 7:52 am ]
Post subject:  Re: Home_built MyIDE external with stock Atari OS chip help

I have got the drive to boot on a semi-regular basis.
But If I wait too long to power up the Atari after powering up the drive, the loader fails.
Also, if I am copying a few files using sio2pc, the copy eventually errors out with an error 144.
It sounds like MyIDE has timing issues with the drive to me.
To even get the loader to load the 4.7 BIOS, I have to power up the drive and then immediately power up the atari with the loader.
Also, I never get any sort of main menu and it boots to MyDOS without BASIC.
Is there anything I can do to improve the situation?
Does the installer for the 4.7 BIOS have a main menu that is accessible?
So many questions, I know.
So now I am stuck and do not know what to do.
BTW, I checked out the interface and added an led so I could at least see when the drive was truly being accessed.
For now, I think the problem is with the timing that is throwing me off.
I have not tried replacing the 74ls545 with that other chip and do not know if they are pin compatible or if that would improve things.
Also, when I get the 144 error, MyBIOS seems to stop working and I get an error 163 trying to get a directory of the IDE drive partitions files,
having 4 partitions.
I have MyDOS installed to drive 2 and it also seems to be installed to drive 1.
So until I can figure this out, I will be back using the factory cartridge with the CF drive.
Now you at least know of my progress.

Author:  mr-atari [ Tue Jun 26, 2012 12:26 am ]
Post subject:  Re: Home_built MyIDE external with stock Atari OS chip help

Some kind of menu for the -D version would be possible, yes.
I'll work on that, not sure when I can supply a new update.

In the meantime, I would like you to double check this behavioure on the ATARIMAX hardware.
But you need to bypass the -F version from loading by holding SHIFT.
Just boot the LOAD47D disk and check your findings from your homebrew interface with ATARIMAX.
Then report your findings here in the forum.

Since you are used to the old utility disk by now, run the SCANDISK.BAS program on both hardware.
Do a deepscan and verify if the data-transfer is 100% error free.

P.S. I tested the -D version on a 2.5" 2Gb Hitachi drive.


Author:  8-bit [ Thu Jun 28, 2012 2:12 am ]
Post subject:  Re: Home_built MyIDE external with stock Atari OS chip help

I have now tried a Toshiba laptop drive and it did not work with the MyIDE cartridge and the early FDISK.BAS reporting no hard drive found. It reported the same with a Conner hard drive, and worked with a Fujutsu drive. But only if I did the start of FDISK immediately after supplying external power to the drive.
When using the disk based software for 4.7F, it would boot every time if I ran the LOAD47E.atr as soon as I supplied power to the drive.
If I waited, the 4.7 hard drive based OS would not load.
So it is working exactly the same as with the home-built card other than the HELP key does not bring up the FDISK using the home built card.
ALT-CTRL-TAB though works.
So I am at a loss as to what is going on. The drive was initially formatted on my PC using XP as FAT32 also if that is pertinent.
I would have thought that the loaded from the drive MyIDE OS and 4.7 BIOS would look and work the same as the one one would burn in replacing the Atari OS.
It was my understanding that there was a main BIOS menu and one game as part of that.
But then again, the docs stated that parts had been removed from the disk versions.
If the OS and 4.7 BIOS will fit on a burned chip that replaces the Atari OS, I cannot fathom why it would not fit on the hard drive.
I will have to double check the cylinder, heads, and sectors per track for that hard drive to make sure I have that set right as it definately would effect the boot process.
Also, have you thought about taking the writing of the OS to the hard drive a step further to have the boot process of the hard drive negate the need to boot a loader to activate and load the OS and 4.7 BIOS?

Author:  mr-atari [ Thu Jun 28, 2012 8:03 am ]
Post subject:  Re: Home_built MyIDE external with stock Atari OS chip help

I do not understand, sorry.
You are on firmware 4.7.05 ?

There were some issues with slow drives on 4.7.04, but these are fixed.

You must see the BIOS is seperate from the bootmenu on atarimax.
Here I do not understand the problem you have.

One thing stands, if you have problems with FDISK.BAS or SCANDISK.BAS do not continue testing other things.
This only makes is confusing, since the device does not work properly.

I tested here on a ATARIMAX with the 4.7.05DE disks and I have no problems.
Even when I wait a few minutes and then run FDISK.BAS it works.

So you got me puzzled.

It does not matter were how and what you had previously on the drive.
Just be sure you use the IDE-MENU to partition it for the Atari

Author:  8-bit [ Thu Jun 28, 2012 5:56 pm ]
Post subject:  Re: Home_built MyIDE external with stock Atari OS chip help

I have just tried my ide2cf adapter with the cf card with my home-built interface and it boots consistently.
If I boot the utilites atr containing the early version of Fdsk,bas, the cf card is found as an external drive too.
But it does not show any of the partitions/drives that I have on it.
They are very present and I can access them just fine when I boot with the load47e.atr!
I also have access to all the features other than a main menu.
When I try the physical hard drives, none show up as being found with the early fdisk even though one will with 4.7e and only if I time the booting of the load46e.atr with the powerup of the external drive with its own power supply.
So it looks to me as if I have major hard drive compatibility problems with the drives.

Sorry if I was misunderstood.
I kept blaming the home-built interface when in the end, it is most likely a hard drive incompatibility problem.
And I say this because of the CF card booting consistently with the external loader file.
As to swapping out the 74ls545 for that other chip, I do not know if that would improve drive compatibility or it is a matter of tapping power from the atari for the external physical hard drive so that it powers up when the atari does.
Buffering the lines on the interface, with caps, I have not tried yet.

Author:  mr-atari [ Fri Jun 29, 2012 1:45 am ]
Post subject:  Re: Home_built MyIDE external with stock Atari OS chip help

What firmware are you running? You can not mix firmwares and expect to work....
Latest stable version is 4.7.05. Please confirm you are using this.

FDISK.BAS is not compatible with a 4.7 partition with MBR.
That's why the partitions don't show up.
FDISK.BAS looks at the wrong sector and uses that data as partition-data.

Did the drives work on the ATARIMAX? I can't remember your answer.
Also try them using SHIFT at bootup, this will get you in the standaard OS.
Run SCANDISK.BAS to see if the drive is compatible.

Author:  8-bit [ Fri Jun 29, 2012 3:22 am ]
Post subject:  Re: Home_built MyIDE external with stock Atari OS chip help

I have one hard drive that is working consistently with the homebuilt cartridge interface and the CF card too using the 4.7 loader.
The other drives do not show up with the 4.7 disk utilities so I assume they are incompatible.
Both the CF and one hard drive work with the AtariMAX cartridge as well as the home built one.
Two drives do not show up at all, and a third shows but gives a read error when trying to read from the drive.
As to the condition of that drive, I cannot verify it is good.
If the drives using the homebuilt interface could load the 4.7 OS + BIOS without having to boot an external loader, that would be great.
But since the atari does not see the external drive till the 4.7 OS is loaded to replace the stock one, I assume that is an impossibility.
Anyway, it has been a learning experience.
I want to mention while I am typing this that someone over on the AtariAge forum has made available 4 16meg disks containing PicoDOS and about 3000 games. But a disk copy is out as the atari stops numbers at 32768. So a diskcopy will not work.
I can copy the directories and files over to a 16meg drive/partition, but do not know how to install picodos to it so it will boot that dos.
Also, I typed in a basic program that creates a autorun.sys file. But that seems to be bypassed on booting the MyIDE cartridge disk with BASIC.
So I am just guessing autorun.sys files will not work with the cartridge.
Anyway, I think I have most of the bugs worked out so I will check out the other home built interfaces I made to see if I can get them to also work too.
As to the version of 4.7, I think the file properties show it as June 12th on the date.
I do not know how to check the exact version I have with either the AtariMAX cartridge or the disk version software as all the zipped files I got are just named with 4.7 and stop there. Why not add another sub version number to the file name so we know what we have or include a way to check the version we are running.

PS. I finally got around to running SCANDISK.BAS on the hard drive. I did a quick scan of the 1.5gig drive and it found 5 bad sectors.
So continued use without connecting it to a pc and running its scandisk on the drive to mark those bad sectors bad would result in corrupted data. Also, when bad sectors develop, usually that means more are on the way.
That is the chance one takes with using used hard drives though.

Author:  mr-atari [ Sun Jul 01, 2012 6:25 am ]
Post subject:  Re: Home_built MyIDE external with stock Atari OS chip help

Try this version with both hardware.
ATARIMAX (holding shift)

SIDE is included, press SHIFT+CONTROL+ESC to activate (when booted)

Author:  8-bit [ Sun Jul 01, 2012 3:03 pm ]
Post subject:  Re: Home_built MyIDE external with stock Atari OS chip help

I tried your new software and it appears to be nice. But if you want someone to test it for stability and bugs, I am not the one to ask.
As I previously stated the external hard drive I was trying to use has issues with bad sectors and after trying the new offering and having it work once, from there on, the loader would not load it correctly as if the hard drive has developed bad sectors in that area and is corrupting things.
So that one is toast.
Also, I went on line to check the specs for the drive as to heads, cylinders, and sectors per track.
We are talking about a 1.5 gig hard drive here.
When I would use the 4.7F fdisk to set up partitions, I set up a bootpart, and started to set up others of 65535 sectors. When I got to setting up the third 65535 sector partition, it showed it as a reduced size like there was not enough room on the drive.
So I would say the drive has problems.
My Transend 512meg card has a 720 sector boot partition, three 65535 sector partitions, and another 720 sector partition with room left for image space.
So to me, it does not make sense that the 1.5gig external drive does not have more capacity.

And that leads me to believe that hard drive has major problems.
And it is not a case of the home-built interface as it also does the same things when hooked up to the AtariMAX cartridge.

One thing I did notice for the time I had the menu of the new software you wanted me to try up, was that the header name was flickering.
But again, you should ask someone with known good hard drives to check out this new software.
I know it took a lot of effort by you to create it and I appreciate that.

For now, I am going to continue to just use the AtariMAX cartridge with the CF card until I come up with another small hard drive.
Thank you again for your efforts!

Author:  roye [ Sun Jul 01, 2012 11:32 pm ]
Post subject:  Re: Home_built MyIDE external with stock Atari OS chip help

mr-atari wrote:
Try this version with both hardware.
ATARIMAX (holding shift)

SIDE is included, press SHIFT+CONTROL+ESC to activate (when booted)

This is great SIDE works real good. I am using one of the first IDE carts you made for me, before the 74f series and a small 125meg CF card. My ATARIMAX CART is full of the SDX stuff so I don't use it for games.

Thank you for this version..

Author:  mr-atari [ Mon Jul 02, 2012 2:08 am ]
Post subject:  Re: Home_built MyIDE external with stock Atari OS chip help

In facebook I would say : "like" :-)

Author:  8-bit [ Tue Jul 03, 2012 11:29 am ]
Post subject:  Re: Home_built MyIDE external with stock Atari OS chip help

A little while back, you asked me what revision of the 4.7 BIOS I was using.
It was in fact as shown briefly on one of the screens. I cannot remember which one though.
I have been trying to make a personalized game directory for use with PICODOS.COM as a loader.
That is unless you can suggest a binary game loader that I can use with a personalized directory full of favorite binary games.
Also, can you suggest a good Atari text editor and a good disk sector editor.
I currently have (from ANALOG Computing magazine) TEXTPRO and DISKEDITOR.
Both were machine language type in programs from the ANALOG magazine.

Author:  mr-atari [ Wed Jul 04, 2012 12:30 am ]
Post subject:  Re: Home_built MyIDE external with stock Atari OS chip help

You figured out the firmware, great :-)
Yep, it's on the powerup/bootscreen.

I always used mini office and diskwizzard.

Picodos is a good gamedos.
You need to download the install disk from the makers homepage.
I have no problems running 16mb picodos partitions from IDE.

About your small harddrive:
You didn't try control-I in the IDE_menu to increase partitionspace and decrease imagespace?
That is normally done when you need more room for partitions.......

2nd note about harddrives:
If they do not work on the ATARIMAX hardware with the F-firmware:
Throw them away.
If they do work but give bad sectors on homebrew-IDE running SCANDISK:
You need to do the 74LS573-modification to buffer the adress-lines A0-A2

Page 1 of 2 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group